Joining an Existing Project

Once somebody has created a project, you may join it by selecting Join from the Project menu. The immediate result of joining is that Code Co-op generates a special "join request" script that will be sent to an existing member of the project. It will be routed to the project administrator—this is usually the person who created the project. Once the administrator executes your "join request", his Code Co-op will generate a special "full-sync" script and send it back to you. When you execute that script, your project tree will be populated with the exact copies of the files and folders that the administrator had in his project. You'll have a full copy of the whole project on your machine.


How to Join a Project

After you select Project > Join, you will answer some questions in the Join Dialog.

Project Options

During the join process, you also can set some project options. The Options tab of the Join Project dialog gives you the following choices:

 

There is a step-by-step tutorial that can lead you through the process of creating and joining projects.