Visual C++ 6.0 Source Control Settings

To improve how Visual C++ 6.0 and Code Co-op work together, you can modify Visual C++ 6.0's's Source Control options. In Visual C++ 6.0, click on the Tools menu and select Options. In the Options dialog, click on Source Control tab. You'll see several options.


Here are our recommendations for Visual C++ 6.0 Source Control options:

Putting Visual C++ 6.0 Workspaces and Projects under version control

If you have an existing Visual C++ 6.0 Workspace, here's how to associate it with a Code Co-op project.

Let's say the workspace file for your project is in c:\work\projects\KillerApp\KillerApp.dsw

  1. In Code Co-op, create a new project (via the Project menu). For the project location ("Where to find or create  the project"), enter a the directory that contains the workspace file. In our case, that would be c:\work\projects\KillerApp
  2. Open the workspace in Visual C++ 6.0 (an easy way to do this within Code Co-op is to right click on the .dsw file and select Open with Shell.
  3. In Code Co-op, click on the Check In Area tab and you'll see all the newly added files. Click on the All menu menu item and select Check In. Enter a comment (e.g. First versions), and click OK. All workspace and project files are now checked in to the Code Co-op project.

Your Visual C++ 6.0 workspace is now fully integrated with your Code Co-op project. You can open the workspace in Visual C++ 6.0 and get to work.

 

Putting additional Visual C++ 6.0 projects under version control

After your Visual C++ 6.0 workspace is under version control, you might add new Visual C++ 6.0 projects to your workspace. To add these projects to your Code Co-op project, it's simplest to let Visual C++ 6.0 add it for you. And to make it easy to see which files are being added and changed, it's best not to have other files in the project checked out when you are adding a new project to version control.

  1. In Visual C++ 6.0, open your workspace and in the workspace window right click on the project you want to add to source control. Select Add to Source Control. Visual C++ 6.0 adds the project files to the Code Co-op project.
  2. Now close the workspace in Visual C++ 6.0.
  3. In Code Co-op, click on the Check In Area tab and you'll see all the newly added files. Select the Click on the All menu menu item and select Check In. Enter a comment (e.g. New sub-project), and click OK. The files are now checked in to the Code Co-op project.

Your new Visual C++ 6.0 project is now fully integrated with your Code Co-op project. You can open the workspace in Visual C++ 6.0 and get to work.

 

Putting a new Visual C++ 6.0 Workspace under version control

If you are going to create a new Visual C++ 6.0 Workspace, here's how to associate it with a Code Co-op project.

Let's say you plan to create your new Visual C++ 6.0 Workspace in the directory c:\work\projects\NextApp

  1. If you don't already have a Code Co-op project that covers c:\work\projects\NextApp, create one (via the Project menu). For the project location ("Where to find or create the project"), enter a the directory that will contain the workspace file. Note, in our case, that would be c:\work\projects\NextApp
  2. In Visual C++ 6.0 create a new Workspace, and enter the location you selected above (e.g. c:\work\projects\NextApp ). When Visual C++ 6.0 creates your workspace and project, it will ask you if you want to put the newly created project under source code control. Click Yes.
  3. Visual C++ 6.0 will show you the files it will add. Click OK.
  4. Now close the workspace in Visual C++ 6.0
  5. In Code Co-op, click on the Check In Area tab and you'll see all the newly added files. Click on the All menu menu item and select Check In. Enter a comment (e.g. First versions), and click OK. All solution files are now checked in to the Code Co-op project.

Your Visual C++ 6.0 workspace is now fully integrated with your Code Co-op project. You can open the workspace in Visual C++ 6.0 and get to work.